プログラミングと旅と映画の日々

普段はスマホ決済サービスのバッグエンドを担当しているエンジニアです。プログラミングと趣味の映画、株、時々うどんに関してブログを書いていこうと思います。海外ドラマ、クロスバイクも好きです。

【maven】usage of api documented as @since 1.8の対処法【java】

intellijjavaのstreamを使おうとしたところ、

usage of api documented as @since 1.8

とエラーが表示されて、compileエラーとなった。


以下のように`maven-compiler-plugin`のsourceとtargetのversionを明示したところ解決

        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.3</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>